detecting version match/mismatch between core/plugins

Wichmann, Mats D mats.d.wichmann at intel.com
Fri Aug 18 01:21:55 BST 2006


>From the beginning I was thinking of the way Firefox
>extensions are handled - there's definitely interaction
>with a registry site to answer these sorts of questions.
>However for a plugin which *is* intended to be in
>lockstep with bzr releases, it does seem reasonable
>to spit out some sort of warning like the above.

To be a little more descriptive, I upgraded Firefox
on a system just now and got this screen:

===
The following components are not compatible with the
new version of Firefox you have just installed:

SessionSaver .2 0.2.1.028

They have been disabled until compatible versions
are installed.

Firefox can check for and install newer, compatible
versions of these components.

===

So at least I'm not surprised by an ugly-looking Python
exception traceback printout when something went
amiss because of version skew :)





More information about the bazaar mailing list