PING [MERGE REVIEW] create_checkout_convenience
aaron.bentley at utoronto.ca
Mon Aug 14 16:12:24 BST 2006
-----BEGIN PGP SIGNED MESSAGE-----
Martin Pool wrote:
> On 14 Aug 2006, Aaron Bentley <aaron.bentley at utoronto.ca> wrote:
> Is there any strong reason why it can't just be create_checkout?
I'm happy to call it create_checkout. I was just imitating the naming
> think the original static method was called that because of the special
> behaviour of using the default format, but we can gradually move to
> controlling that with an option parameter within this method.
I thought create_branch_convenience was named that because the method
was meant to be used at a high level, and so it was a bit DWIMish.
>>+ :param lightweight: If True, produce a lightweight checkout, othewise
>>+ produce a bound branch (heavyweight checkout)
Thanks for the +1. I've submitted it with your changes.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org
-----END PGP SIGNATURE-----
More information about the bazaar