Nomenclature
Gustavo Niemeyer
gustavo at niemeyer.net
Fri Sep 30 14:42:44 BST 2005
Greetings!
Since I've been coding in bzr, I've perceived that some parts of the
code are slightly inconsistent regarding nomenclature. This is
certainly not a major issue, and is of course trivial to fix. Even
then, I'd like to bring some of them to your attention.
I belive it'd be worthwhile to fix them at some point, and possibly
introduce a convention to guide future development. At this stage
it's hard to tell what convention one should follow when writing
new code.
* revno vs. rev_id
* branch.get_revision_*() vs. branch.revision_*()
* branch.get_rev_id() vs. branch.revision_id_to_revno() vs. *.id2*()
* branch.get_*() vs. branch.(!get_)*() in general
* branch.controlfilename() and branch.controlfile() vs.
branch.revision_history()
* inventory.get_idpath() vs. inventory.id2path() (what's the
difference?)
* osutils.isfile()/isdir() vs. osutils.is_inside()/is_inside_any()
* osutils.filesize() vs. osutils.sha_file() vs. osutils.file_kind()
* osutils.splitpath() vs. osutils.split_lines()
* weave.idx_to_name() vs inventory.id2path()
* weave.numversions() vs weave.*_*()
* weavestore.filename() vs. weavestore.get_*()
* weavestore.file_class() vs. weavestore.get_file_*()
* weavestore.ignored_files() vs. weavestore.get_ignore_list()
--
Gustavo Niemeyer
http://niemeyer.net
More information about the bazaar
mailing list