[PATCH] Use best available python version

Aaron Bentley aaron.bentley at utoronto.ca
Mon May 30 12:28:13 BST 2005


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Michael Ellerman wrote:
> On Mon, 30 May 2005 16:10, Lalo Martins wrote:
> 
>>On Mon, 2005-05-30 at 14:09 +1000, Michael Ellerman wrote:
>>
>>>Hi,
>>>
>>>On my Debian box I have Python 2.4, but Python 2.3 is the default.
>>>Currently bzr settles for Python 2.3, this patch makes it use 2.4 in
>>>preference if it's there.
>>
>>er, why?
> 
> 
> Well mainly because I grabbed the latest bzr and it was broken for 2.3.

That's an opportunity.  A chance to fix bugs in the 2.3

This is specifically why I haven't switched my default Python version to
2.4-- I want to ensure my patches work on 2.3.

Since the user controls their default Python version, let's respect
their choice.

Aaron
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFCmvjM0F+nu1YWqI0RArDmAJ4sIjb1a4q+w0FmsPEk1U4S6VCTsQCfTcms
RAEVpC3W/x8/GUCk/XCj7xE=
=S4bL
-----END PGP SIGNATURE-----




More information about the bazaar mailing list