Rev 6395: Cannot use ExpectedException as pqm provides only testtools-0.9.8, 0.9.9 needed in file:///home/vila/src/bzr/experimental/memory-stack/

Vincent Ladeuil v.ladeuil+lp at free.fr
Wed Dec 21 15:18:21 UTC 2011


At file:///home/vila/src/bzr/experimental/memory-stack/

------------------------------------------------------------
revno: 6395
revision-id: v.ladeuil+lp at free.fr-20111221151821-gdtgtnk1ppd3r09w
parent: v.ladeuil+lp at free.fr-20111221142526-pnwau0xnalimujts
committer: Vincent Ladeuil <v.ladeuil+lp at free.fr>
branch nick: memory-stack
timestamp: Wed 2011-12-21 16:18:21 +0100
message:
  Cannot use ExpectedException as pqm provides only testtools-0.9.8, 0.9.9 needed
-------------- next part --------------
=== modified file 'bzrlib/tests/test_config.py'
--- a/bzrlib/tests/test_config.py	2011-12-21 14:25:26 +0000
+++ b/bzrlib/tests/test_config.py	2011-12-21 15:18:21 +0000
@@ -3410,8 +3410,7 @@
         conf = config.MemoryStack()
         # No content means no loading
         self.assertFalse(conf.store.is_loaded())
-        with testtools.ExpectedException(NotImplementedError):
-            conf.get('foo')
+        self.assertRaises(NotImplementedError, conf.get, 'foo')
         # But a content can still be provided
         conf.store._load_from_string('foo=bar')
         self.assertEquals('bar', conf.get('foo'))



More information about the bazaar-commits mailing list