Rev 4735: downgrade the rename warnings to mutters. in http://bazaar.launchpad.net/~jameinel/bzr/2.0.4-autopack-rename-507557

John Arbash Meinel john at arbash-meinel.com
Thu Jan 21 19:27:03 GMT 2010


At http://bazaar.launchpad.net/~jameinel/bzr/2.0.4-autopack-rename-507557

------------------------------------------------------------
revno: 4735
revision-id: john at arbash-meinel.com-20100121192640-de9zrkpyfpimwhj1
parent: john at arbash-meinel.com-20100121192426-uqybtanmedljv60o
committer: John Arbash Meinel <john at arbash-meinel.com>
branch nick: 2.0.4-autopack-rename-507557
timestamp: Thu 2010-01-21 13:26:40 -0600
message:
  downgrade the rename warnings to mutters.
  
  It is fairly likely that a concurrent autopack will run into this,
  so we'll go ahead and only mutter(). It doesn't indicate a problem,
  so we don't need to scare the user.
-------------- next part --------------
=== modified file 'bzrlib/repofmt/pack_repo.py'
--- a/bzrlib/repofmt/pack_repo.py	2010-01-21 19:24:26 +0000
+++ b/bzrlib/repofmt/pack_repo.py	2010-01-21 19:26:40 +0000
@@ -1790,8 +1790,8 @@
                     '../obsolete_packs/' + pack.file_name())
             except (errors.PathError, errors.TransportError), e:
                 # TODO: Should these be warnings or mutters?
-                warning("couldn't rename obsolete pack, skipping it:\n%s"
-                        % (e,))
+                mutter("couldn't rename obsolete pack, skipping it:\n%s"
+                       % (e,))
             # TODO: Probably needs to know all possible indices for this pack
             # - or maybe list the directory and move all indices matching this
             # name whether we recognize it or not?
@@ -1803,8 +1803,8 @@
                     self._index_transport.rename(pack.name + suffix,
                         '../obsolete_packs/' + pack.name + suffix)
                 except (errors.PathError, errors.TransportError), e:
-                    warning("couldn't rename obsolete index, skipping it:\n%s"
-                            % (e,))
+                    mutter("couldn't rename obsolete index, skipping it:\n%s"
+                           % (e,))
 
     def pack_distribution(self, total_revisions):
         """Generate a list of the number of revisions to put in each pack.



More information about the bazaar-commits mailing list