[apparmor] [Patch] fix create-apparmor.vim.py for python 2.5

John Johansen john.johansen at canonical.com
Fri Jun 8 19:50:40 UTC 2012


create-apparmor.vim.py was failing on systems with python 2.5, fix that

If this patch is acceptable I would like to nominate it for 2.8.1

---

--- a/utils/vim/create-apparmor.vim.py
+++ b/utils/vim/create-apparmor.vim.py
@@ -9,6 +9,7 @@
 #    Written by Steve Beattie <steve at nxnw.org>, based on work by
 #    Christian Boltz <apparmor at cboltz.de>
 
+from __future__ import with_statement
 import os
 import re
 import subprocess



More information about the AppArmor mailing list