[apparmor] [PATCH 09/16] AppArmor: Move path failure information into aa_get_name and rename

Kees Cook kees at ubuntu.com
Wed Feb 22 20:39:05 UTC 2012


On Wed, Feb 22, 2012 at 09:10:34AM -0800, John Johansen wrote:
> Move the path name lookup failure messages into the main path name lookup
> routine, as the information is useful in more than just aa_path_perm.
> 
> Also rename aa_get_name to aa_path_name as it is not getting a reference
> counted object with a corresponding put fn.
> 
> Signed-off-by: John Johansen <john.johansen at canonical.com>

Signed-off-by: Kees Cook <kees at ubuntu.com>

-- 
Kees Cook



More information about the AppArmor mailing list