[apparmor] [Bug 737074] Re: apache2 apparmor module missing link against libapparmor

Launchpad Bug Tracker 737074 at bugs.launchpad.net
Thu Mar 24 14:00:11 UTC 2011


This bug was fixed in the package apparmor - 2.6.1-0ubuntu1

---------------
apparmor (2.6.1-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Fixes breakage of mod_apparmor apache2 module (LP: #737074)
    - Fixes profile matching when an attachement doesn't contain a
      regex (LP: #731155)
    - Fixes parser acceptance of missing network protocols (LP: #732837)
    - Patches taken upstream and dropped:
      + debian/patches/0002-lp727478.patch
      + debian/patches/0003-test-lp727478.patch
      + debian/patches/0004-lp736870.patch
  * debian/apparmor.install, debian/apparmor.dirs: add new multiarch
    tunable file and directory
  * debian/python-libapparmor.install: loosen directory specification
    for resiliancy against different python versions
 -- Steve Beattie <sbeattie at ubuntu.com>   Thu, 24 Mar 2011 01:55:12 -0700

** Changed in: apparmor (Ubuntu)
       Status: New => Fix Released

-- 
You received this bug notification because you are a member of AppArmor
Developers, which is the registrant for AppArmor.
https://bugs.launchpad.net/bugs/737074

Title:
  apache2 apparmor module missing link against libapparmor

Status in AppArmor Linux application security framework:
  Fix Released
Status in AppArmor 2.6 series:
  In Progress
Status in “apparmor” package in Ubuntu:
  Fix Released

Bug description:
  For some reason, the apparmor 2.6 build of mod_apparmor is failing to
  link properly against libapparmor:

  ubuntu at natty-i386:~$ sudo /etc/init.d/apache2 restart
   * Restarting web server apache2
   ... waiting    ...done.
  ubuntu at natty-i386:~$ sudo a2enmod apparmor
  Enabling module apparmor.
  Run '/etc/init.d/apache2 restart' to activate new configuration!
  ubuntu at natty-i386:~$ sudo /etc/init.d/apache2 restart
  apache2: Syntax error on line 203 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/apparmor.load: Cannot load /usr/lib/apache2/modules/mod_apparmor.so into server: /usr/lib/apache2/modules/mod_apparmor.so: undefined symbol: aa_change_hat
  Action 'configtest' failed.
  The Apache error log may have more information.
     ...fail!
  ubuntu at natty-i386:~$ ldd /usr/lib/apache2/modules/mod_apparmor.so
          linux-gate.so.1 =>  (0x00779000)
          libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0x009fa000)
          /lib/ld-linux.so.2 (0x0018f000)

  (this is with the 2.6.0-0ubuntu2 package in natty, I know
  2.6.0-0ubuntu3 has been uploaded, but nothing should be different in
  that version.)



More information about the AppArmor mailing list